Archiv der Kategorie: Reparatur

Reparatur Samsung TV

…mal kein Amateurfunk-Thema

Der Fehler

Das 46-Zoll-Fernsehgerät eines Bekannten zeigte ein Negativbild. Eine Internetrecherche ergab, dass der Fehler bei einer Vielzahl von Geräten durchaus bekannt ist und der Austausch eines Schaltkreises notwendig sei. Auch wird berichtet, dass es sich bei diesem Fehlverhalten nicht immer um ein Negativbild handelt, sondern auch mal über fehlende Farben usw.

Es handelt sich hierbei um das IC mit der Aufschrift AS15-U im VQFN-Format. Es ist ein 48-Beiner (4×12) in der Größe 7×7 mm. Die Pins haben einen Abstand von 0,5 mm bei einer Pin-Breite von jeweils 0,2 mm ergibt sich ein Abstand von jeweils 0,1 mm. Das IC ist recht günstig für knapp 7 Euro zu bekommen und sieht auf Fotos recht geschmeidig aus.

Ich bekam die ausgebaute Steuerplatine, ein sog. T-Con-Board und einen neuen AS15-U in die Finger und so sah ich zum ersten mal, auf was ich mich da eingelassen hatte. Nun, Fotos sind das Eine, die Realität ist das Andere. Die Herausforderung war es nun den defekten Chip zu entfernen und den neuen wieder aufzulöten. Und wenn ich Herausforderung schreibe, dann meine ich auch Herausforderung. Also habe ich diese Herausforderung angenommen!

Der Ausbau

Mit 350° Heißluft aus der Rework-Station war der Chip dann recht schnell entfernt.

Die Kratzer auf dem Chip kommen von der abgerutschten Pinzette, wenn man ungeduldig ist….

Dann wurden mit einem 360°-Lötkolben und der Entlötlitze alle Lötzinnreste entfernt. Den Dreck habe ich hinterher mit 99% Alkohol (aus der Apotheke) entfernt.

Das Resultat ist eine saubere Platine mit sauberen Lötpads.

Gereiinigte Lötstellen für den AS15-U

Der Einbau

Beim Einbau habe ich zunächst einen Lötpad mit Lötzinn vorbereitet. Den Chip auf alle Pads ausgerichtet und diesen einen Pin kurz angeheftet. Damit kann man den Chip immer noch ausrichten. Das habe ich getan und diagonal gegenüber einen weiteren Pin angelötet.

Danach: Kontrolle auf korrekten Sitz des Chips. Bei diesen kleinen Dingern empfiehlt es sich dringend immer wieder zu kontrollieren. Eine Uhrmacherlupe kann dabei sehr hilfreich sein. Man kann gar nicht genug kontrollieren. Lieber einmal mehr kontrollieren, als neu von vorne zu beginnen und dabei möglicherweise auch teure Materialien zu schlachten.

Jetzt schmierte ich eine Reihe Pins mit Fluxpaste dick ein und nahm die breite Lötspitze, die ich mit einer geschmeidigen Handbewegung und etwas frischem Lötzinn über die Pins fuhr. Danach darf man nicht erschrecken, wenn noch einige Pins mit Lötklecksen verbunden sind. Diese bekommt man mit noch mehr Flux und dem Ausstreichen der Beinchen nach außen mit der breiten Lötspitze alle sauber. Mit einem Küchentuch habe ich dann den Rest Flux abgetupft mit Isopropyl auf einem Wattestäbchen gereinigt und alle weiteren Reihen so angelötet.

Nach der letzten Reinigung bin dann aber am Pin 12, der offensichtlich nicht korrekt angelötet war, mit dem Lappen hängen geblieben. Dabei brach der Pin ab. Also war’s nicht sauber gelötet und schlecht kontrolliert.

Schaden mit dem Reinigungslappen am Pin 12

Der zweite Einbau

Zunächst wieder mit Heißluft den alten Chip heraus schmelzen, Platine reinigen und wie oben beschrieben den neuen Chip einsetzen, verlöten und wieder die Platine reinigen. Hier das Ergebnis:

Saubere Lötstellen und saubere Platine.

Und nochmal: Kontrolle, Kontrolle, Kontrolle, … und Kontrolle!
Nach mehrmaligem Suchen fand ich tatsächlich noch eine Verbindung zwischen den Pins. Auch hier half wieder die Uhrmacherlupe, Flux, Entlötlitze und Isopropyl 99%. Für solche Arbeiten habe ich mir einen Durchgangsprüfer gebaut, Die Eigenschaft dieses Gerätes ist, dass mit ganz wenig Spannung und ganz wenig Strom ein extrem niedriger Widerstand gemessen wird. Für Messungen an hochempfindlichen SMDs und CMOS-ICs ist es DAS Prüfgerät auf meinem Basteltisch. Hier der Link: Durchgangsprüfer

 

Fertig

Der Kollege baute die Platine ein und bestätigte mir die erfolgreiche Reparatur seines Samsung Fernsehers.

Fazit: Keine Angst vor zu kleinen Bauteilen. Ich habe viel dazu gelernt!

 

Transistor ausbrennen – Reparatur Signalgenerator SG 31

Ein Senior-OM vermachte mir aus seiner Kramkiste einen Signalgenerator, von dem er meinte, dass er statt HF nur noch NF produziert. Beide Signalarten werden getrennt nach außen geführt. Der Hersteller oder Händler des Gerätes deutet lt. Aufkleber auf CTR-Elektronik in Nürnberg und wurde in den 60er Jahren als “SIGNALGENERATOR SG 31” benannt.

Signalgenerator SG31Auf den ersten Blick erkannte ich, dass mit diesem Gerät einst Signale im Bereich von etwa 150 kHz bis über 300 MHz in acht Bereichen erzeugt wurden. Das NF-Signal kann sogar auf die HF moduliert werden. Auch kann die HF über einen Abschwächer reduziert werden. Wie man später noch sehen wird, handelt es sich hierbei um einen einfachen LC-Generator, der ungefiltert und unstabilisiert jeweils ein NF- und ein HF-Signal an die Frontbuchsen gibt. Und das im Stil der 60er.

EDIT 22.07.2016:
Mittlerweile habe ich durch puren Zufall das Original samt Schaltplan gefunden. Er wurde unter dem Namen “Signal Generator 31” der Firma Nombrex Ltd. (Exmouth, Devon, England) veröffentlicht. Die Beschreibung mit Schaltplan kann bei mir angefragt werden.

NF-Signal am Ausgang des SG31

NF-Signal am Ausgang des SG31

Vorsichtig steckte ich die Zuleitung in die Steckdose, es knallte nichts, es ging auch nichts in Rauch auf. Dann schaute ich mir die Ausgangssignale am Oszilloskop an. Das NF Signal von ca. 600 Hz liegt mit einer Spannung von ca. 7 Volt am Ausgang. Auch habe ich schon sauberere Signale gesehen. Belastet man den Ausgang, z.B. mit einem Aktivlautsprecher,  geht das Signal schon sehr in die Knie. Also kann man hier im Inneren auch keine großartigen Mechanismen zur Auskopplung erwarten.

Am HF-Ausgang war auch nicht mit Drehen und Würgen der Knöpfe und Schalter irgendein Signal zu erkennen.

Also schraubte ich das Gerät erst mal auf…

Platine SG31Wie schon erwartet, sind hier Bauteile aus den frühen 60er Jahren verbaut. Geschockt vom Anblick der für heute recht unüblich anmutenden Kondensatoren und Widerstände fielen mir neben dem großen Umschalter der Frequenzbänder und dem Drehkondensator zwei Transistoren auf. Auch ein Netzteil wurde offensichtlich als Eigenbau nachträglich eingebaut. Messungen ergaben hier eine Betriebsspannung von 13,7 Volt, stabilisiert mit einer Kombination aus Zenerdiode 9v1 und PNP-Transistor 2N2905 (???), was ja irgendwie nicht so ganz stimmen kann. Dazu später aber mehr. Ein Batteriehalter für 9V-Blöcke lässt vermuten, dass der Signalgenerator auch mobil eingesetzt werden könnte. Davon war im Gerät aber nichts mehr zu erkennen.

HF-Teil SG31 mit Transistor CV7089

HF-Teil SG31 mit Transistor CV7089

NF-Teil SG31 mit Transistor 2G371A

NF-Teil SG31 mit Transistor 2G371A

Frequenzbandumschalter SG31

Frequenzbandumschalter SG31

 

 

 

 

 

 

Bei den Transistoren handelt es sich um Germanium-Transistoren vom Typ 2G371A und CV7089. Internetrecherchen ergaben nun:

Originaltyp

Ersatztyp

Zweck

2G371, 2G371A AC126, 2N2431 NF-Transistor in Audio- und Videogeräten
CV7089 OC171, AF114-AF117, AF124-127 HF-Transistor, Grenzfrequenz bei ca. 75 MHz

Bevor ich mich aber zuerst um die aktiven Komponenten kümmerte, wollte ich mir ein Bild vom Zustand der Leiterbahnen und Lötpunkte machen. Ich entfernte die Knöpfe, die die Platine von hinten an der Frontplatte halten. Profilaktisch lötete ich zunächst alle Lötpunkte nach und nahm das Gerät mit einem Oszilloskop am HF-Ausgang wieder in Betrieb. Der Ausgang blieb stumm. So baute ich dann den CV7089 aus und miss ihn durch. Die Werte waren ok, auch im Transistortester meines Multimeters zeigte der Transistor einen brauchbaren hFE-Wert an. Also baute ich ihn wieder ein und ging nochmal auf die Suche. Ich bemerkte beim Schalten des Bandschalters, dass ab und zu mal ein Signal vorhanden war. Und plötzlich hatte ich Signal am HF-Ausgang. Waren die Schaltkontakte korrodiert? Nein, denn die hatte ich zuvor mit etwas Spray gereinigt. Plötzlich war das Signal auch wieder weg und der Oszi (nicht zu verwechseln mit einem Ossi) zeigte wieder eine Nulllinie.

Ich maß die Spannungen am Transistor und stellte fest, dass die Versorgungsspannung am Emitter fehlte, die im ausgebauten Zustand des Transistor noch die vollen 9 Volt anzeigte. Ich hatte es hier offensichtlich mit einem klassischen Kurzschluss zu tun. Aber wo?

Parallel zu meinem Kurzschluss bewegte ich mich im Internet auf den verschiedensten Seiten und Foren. Der CV7089 ist nicht mehr erhältich, lediglich der Ersatztyp OC171. In England bestellte ich mir erst mal zwei Stück für unter 10 Euro. Nach und nach kam ich über diverse Foren auch auf Seiten, die sich mit einem offensichtlichen Geheimnis dieser Transistortypen in diesen TO-7-Gehäusen beschäftigten. Dort waren die Symptome ähnlich wie bei meinem Transistor. Ich nahm mir den Transistor also nochmal unter die Lupe und maß den Widerstand zwischen den Beinchen und dem Abschirmgehäuse. Es zeigte sich ein Widerstand von 24 Ohm vom Kollektor zum Gehäuse. Das ist nicht weiter schlimm, weil das vierte Beinchen des Transistors für das Gehäuseblech abgekniffen war. Es zeigte sich aber auch ein Widerstand von etwa 16 Ohm zwischen Emitter und Gehäuse. War der Transistor defekt? Er funktionierte doch kurzzeitig und sogar auch ein zweites mal, aber dann halt auch wieder nicht mehr.

Das Geheimnis, die Ursache:

Alten Hasen wird das Folgende nichts Neues mehr sein. Diese Transistoren bilden im Laufe der Zeit kleine leitende Kristallnadeln, sog. Whiskers, die sich in einer Art Gel von der Gehäusewand zu den Elektroden ausbilden. Dabei müssen die Transistoren noch nicht einmal in Betrieb (gewesen) sein. Jetzt erklärte sich auch der “Kurzschluss” zwischen den Elektroden. Bei den Ersatztypen, wie OC171, sollen sich diese Whiskers angeblich auch gebildet haben. Jedoch bei den AF-Typen sind keine solchen Probleme bekannt geworden. Übrigens hat die NASA um die Erforschung der Whiskers einige Präsentationen im Internet veröffentlicht. Wiki’s Pedia ist hier eine sehr gute Adresse zum Nachschlagen.

Auch dieser Link könnte helfen: http://nepp.nasa.gov/whisker/index.html

Die Lösung – Ausbrennen:

Man kann die Kristalle elektrisch “ausbrennen”. Dazu habe ich die drei Beinchen für E-B-C zusammen gedrillt und mit einer Spannung von 30 Volt aus meinem Labornetzteil zwischen den Beinchen und dem Gehäuse versehen. Dabei ist es egal, wo Plus und Minus anliegen. Ich vermutete nun einen kleinen Ruck, aber es kam nichts. So legte ich nochmal die Spannung von jedem einzelnen Anschluss gegen das Gehäuse. Auch jetzt war nichts zu spüren. Alles war wohl sauber vom Gehäuse getrennt, keine Kurzschlüsse mehr. Ich lötete den Transistor nun wieder an seinen Platz und schaltete das Gerät ein.

Nun war endlich wieder ein Signal an der HF-Ausgangsbuchse zu vernehmen, und ich konnte in allen acht Bereichen schalten und bekam mehr oder weniger saubere (Sinus-) Signale auf den Schirm. Mein Oszilloskop hat leider eine Grenzfrequenz bei 20 MHz. Deshalb habe ich mal den USB-Stick als Spektrumanalysator mit dem Signal gespeist. Hier ein Signal im 144 MHz Bereich.

144 MHz Spekttrum SG31

Ich befestigte eine Hohlbuchse für eine externe Spannungsversorgung und speiste die Schaltung zunächst von meinem Labornetzteil mit 9 Volt. Die gesamte Schaltung benötigt in Volllast übrigens nicht mehr als 15 mA. Als ich aber am Versorgungskabel wackelte, machte sich das sofort als Frequenzsprünge bemerkbar. Dies ist also keine gute Lösung. Auch ein Klopfen am Gehäuse erzeugt ein hörbares NF-Signal in der Demodulation.

Spektrum 144 MHz Beeinflussungen

12V Netzteil SG31Das alte (angebliche) 9V-Netzteil (mit 13,7V Ausgang) war lediglich in das Gehäuse eingeklebt und bröckelte auch schon auseinander. Auch war der ursprüngliche NPN-Transistor durch einen 2N2905 PNP-Typ ersetzt.

Auf einer Lochrasterplatine habe ich nun das Netzteil neu aufgebaut. Dabei stellte ich fest, dass der falsche PNP-Transistor und die 9,1V Zenerdiode kaputt waren. Durch die Schlüsse wurden immerhin 13,7V aus dieser Stromfabrik erzeugt. Also einmal schütteln und nach Lösung suchen. Leider hatte ich in meiner Kiste nur eine 10V-Zenerdiode und einen 2N5901 Leistungstransistor. Dieser ist eigentlich ein HF-Transistor mit einem Frequenzgang bis 1200 MHz und irgendwie viel zu schade für eine solche simple Schaltung, aber es ist der einzige, den ich grad zur Hand hatte. Also baute ich das kleine Netzeil nach diesem Plan auf:

2016-01-20 13_31_47-Dokument1 - Microsoft WordFür den C2 kann man auch einen 220µF Elko einsetzen. Der Widerstand R2 wird leicht warm, er sollte mit etwas Abstand von der Platine befestigt werden.

Jetzt ist die HF am Ausgang durch die fehlenden externen Einflüsse wesentlich stabiler. Im übrigen funktioniert die Schaltung zwischen 8V und 18V Betriebsspannung. In der Galerie können noch weitere Bilder vom Oszi betrachtet werden.

 

Weiter werde ich an der Rückseite noch aktuell gängige Anschlussbuchsen anbringen, um die Originalansicht der Frontplatte nicht zu zerstören.

Es ist an der Zeit

Die GAP Titan DX hat mir ja bis heute gute Dienste geleistet. Allerdings war die Resonanz der Antenne bei 80m, 40m und 15m ausßerhalb der Amateurfunkbänder, was dann nur noch mit einem Antennentuner gut funktionierte, 80m aber gar nicht.
Heute habe ich die GAP heruntergenommen (das wollte ich ja schon letztes Frühjahr), auseinander gebaut und erstmal in die Ecke gestellt, um meine Studien an den Stangen und Stäben daran auszulassen. Mal schauen, woran es liegt… war es letztendlich vielleicht doch die Dachkapazität? War es der Missmut der XYL, der die schlechte Resonanz auf diesen Bändern lieferte?
Wenn ich sie wieder zusammen bauen und aufstellen sollte, so wird sie besser als zuvor strahlen. Ob und wann das sein wird, ist nicht geklärt.

Operation Baofeng Antenne

Operation an Baofeng HFG-Antenne

Das Baofeng UV5R+ läuft bei mir seit der Anschaffung vor über einem Jahr im Auto (mobil) und in der Brusttasche (portabel) quasi pausenlos im Dauereinsatz und ist mir ein zuverlässiger Freund geworden. So sehen die Knöpfe auch schon recht abgegriffen aus. Der Wechsel vom Portabel- zum Mobilbetrieb Im Auto erfolgt dann immer mit dem Abschrauben des Gummipüppel und der Verbindung mit einer Mobilantenne über einen BNC-Adapter.

Operation Baofeng Antenne

Operation Baofeng Antenne

In der letzten Zeit bemerke ich aber immer wieder extreme Wackler beim Einsatz der originalen Duoband-Antenne. Da musste ich unbedingt mal reinschauen. Und hier der Operationsbericht:

Nach dem Abheben des Etikettenringes kann man die Antenne aus dem Gehäuse herausheben. Dazu muss man eine Raste und zusätzlich einen Gummikleber im Gehäuse innen überwinden. Also mit etwas behutsamer Kraft. Dann kommt die eigentliche Antenne zum Vorschein.

Operation Baofeng Antenne

Operation Baofeng Antenne

Operation Baofeng Antenne

Operation Baofeng Antenne

Operation Baofeng Antenne

Operation Baofeng Antenne

Das Signal wird über einen Kondensator im inneren der Antennenfeder bei etwa 2cm eingespeist, dessen Lötkontakt am Stecker abgerissen ist.

Operation Baofeng Antenne

Operation Baofeng Antenne

Operation Baofeng Antenne

Operation Baofeng Antenne

Operation Baofeng Antenne

Operation Baofeng Antenne

IF

Um den Kondensator wieder zu befestigen, lötete ich am Speisepunkt der Feder den Kondensator ab und lötete ihn zuerst am Stecker an.

Operation Baofeng Antenne

Operation Baofeng Antenne

Danach schraubte ich die Antennenfeder wieder auf den Stecker und konnte mit ein bisschen Fluchen das andere Beinchen des Kondensators wieder an der Antenne befestigen.

Operation Baofeng Antenne

Operation Baofeng Antenne

Der Rückbau erfolgte dann in umgekehrter Reihenfolge. Auf einen Kleber verzichtete ich erstmal und erwarte nunmehr irgendwann eine erneute Operation. Dafür habe ich ein wenig Spielraum gelassen. Mal schauen, wann ich da wieder ran muss…

Gesucht: Mikrofon im Baofeng UV5R+

Die Lautstärke im Baofeng UV5R+ lässt etwas zu wünschen übrig. Deshalb machte ich mich auf die Suche nach dem Mikrofon. Dies befindet sich unter der Frontabdeckung hinter einem 1mm großen Loch. Kein Wunder, dass da nicht viel an Sprechdruck reingeht.

So wollte ich dieses Loch vergrößern. Um nicht Gefahr zu lauifen, dass ich im Innern des Gerätes etwas zerstöre, entscheide ich mich die Aktion von innen/hinten durchzuführen. Also muss das Gerät zerlegt werden.

Zunächst nehme ich die Blende um das Display herum ab. Dazu löst man einfach nur die beiden Torx-Schrauben, die sich jeweils in den oberen Ecken befinden. So habe ich dann als erstes dieses Loch auf 3mm erweitert.

Baofeng UV5R+ Frontplatte

Baofeng UV5R+ Frontplatte

Das Loch dahinter ist ebenfalls nur 1mm groß. Deshalb habe ich das Gerät komplett geöffnet. Nachdem der Akku und die Antenne entfernt ist, löst man vier Torx-Schrauben in den Ecken und die zwei Kreuzschlitzschrauben, die für den Gürtelclip dienen. Dann noch den Lautstärke-Knopf abziehen und die Überwurfmuttern des Lautstärkepotis und über der Antennenbuchse gelöst. Mit ein bisschen Hebeln bekommt man dann die ganze Platine heraus.

Baofeng UV5R+ offen

Baofeng UV5R+ offen

Nun habe ich die kleine Mic-Öffnung auf 3mm erweitert.

Baofeng UV5R+ Frontplatte von innen

Baofeng UV5R+ Frontplatte von innen

Das Ganze baut man in der umgekehrten Reihenfolge wieder zusammen.

Der erste Test hört sich vielversprechend an, jetzt kommt dreimal soviel Druck auf die kleine Mikrofonkapsel. Allerdings auch Wind und Pustegeräusche. Wenn man sich dann angewöhnt an dem Mikrofon vorbei zu sprechen als direkt hinein, hat man eine saubere Modulation. Man könnte vielleicht noch einen Spuckschutz hinterkleben, ein Stück Nylonstrumpf kann hier nicht schaden. So wird die XYL auch wieder mit in das Hobby eingebunden.

Standard C500

PTT-Aussetzer am Standard C500 mit externem Mikrofon

Standard C500 als Basisstation

Standard C500 als Basisstation

Mein Standard C500 benutze ich immer noch als Stationsgerät. Eingespannt in einen Spielzeugschraubstock habe ich mir mal vor Urzeiten ein externes Lautsprechermikrofon zugelegt. Durch die mechanische Beanspruchung am Stecker durch den ständigen Zug haben sich am 30 Jahre alten Gerät die Kontakte verschleißt. Und so passierte es, dass ich mitten in meinen Gesprächsdurchgängen Weiterlesen